Skidim.com Discussion Board Homepage
Forum Home Forum Home > Engine Or Boat Troubles > Problems & Solutions
  New Posts New Posts RSS Feed - Warning Buzzer
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Topic ClosedWarning Buzzer

 Post Reply Post Reply
Author
Message
Caltod01 View Drop Down
New Member
New Member


Joined: 08 July 2014
Location: Ringgold Ga
Status: Offline
Points: 2
Direct Link To This Post Topic: Warning Buzzer
    Posted: 08 July 2014 at 7:07pm
Have a 87 MC PS 190 and just recently buzzer comes on at engine start and stays on constantly. Temp is ok; Oil press is good; and charging is good also. Bilge is working fine and boat run great just buzzer will not go off. This is my 1st in board and only 2nd boat so I was hoping someone may be able to give me some direction as to what else to check??
Caltod01
Back to Top
67+91 Nautiques View Drop Down
New Member
New Member
Avatar

Joined: 24 July 2004
Location: United States
Status: Offline
Points: 5
Direct Link To This Post Posted: 12 August 2014 at 6:32am

If it is like my 90 sport nautique and  it is working,  then it is telling you that the oil pressure is low or the voltage is low. 

I have a 90 sport Nautique, with the same buzzer problem.
In mine it was the module that the sensors go into went bad. My module had the oil pressure, eng temp, voltage. 

I could see on the gauges that the oil pressure was good ( 60 ) and voltage was good 13+. So it was the module. If your oil pressure is good and the voltage is good   then a quick short term solution is just disconnect the buzzer but watch your gauges as the buzzer will no sound if the temp goes up, the oil pressure drops or the voltage drops.    The get the module checked out. 
67 Mustang, 90 Sport Nautique
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.016 seconds.